INTRODUCTION TO A FINITE ELEMENT ANALYSIS PROGRAM:

ANSYS
Table of contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>3</td>
</tr>
<tr>
<td>Short history</td>
<td>3</td>
</tr>
<tr>
<td>Basic program structure</td>
<td>3</td>
</tr>
<tr>
<td>Preprocessor</td>
<td>5</td>
</tr>
<tr>
<td>Solution processor</td>
<td>5</td>
</tr>
<tr>
<td>Postprocessor</td>
<td>6</td>
</tr>
<tr>
<td>Tutorial 1: Truss problem</td>
<td>7</td>
</tr>
<tr>
<td>Geometry</td>
<td>8</td>
</tr>
<tr>
<td>Material</td>
<td>9</td>
</tr>
<tr>
<td>Element type</td>
<td>10</td>
</tr>
<tr>
<td>Mesh</td>
<td>11</td>
</tr>
<tr>
<td>Loads</td>
<td>11</td>
</tr>
<tr>
<td>Solution</td>
<td>12</td>
</tr>
<tr>
<td>Results</td>
<td>12</td>
</tr>
<tr>
<td>Tutorial 2: Beam problem</td>
<td>14</td>
</tr>
<tr>
<td>Geometry</td>
<td>14</td>
</tr>
<tr>
<td>Material</td>
<td>14</td>
</tr>
<tr>
<td>Element type</td>
<td>15</td>
</tr>
<tr>
<td>Mesh</td>
<td>15</td>
</tr>
<tr>
<td>Loads</td>
<td>15</td>
</tr>
<tr>
<td>Solution</td>
<td>16</td>
</tr>
<tr>
<td>Results</td>
<td>16</td>
</tr>
</tbody>
</table>
Introduction

The following pages should give you a brief and basic introduction to the architecture and structure of a commercial finite element analysis program. The basic ideas can be applied in most programs but examples are taken from the software ANSYS. We will here only focus on structural mechanics in ANSYS. Note also that many steps can be done in several other ways than what is presented here.

Short history

The usage of the Finite Element Method as a tool to solve engineering problems commercially in industrial applications is quite new. It was used in the late 1950’s and early 60’s, but not in the same way as it is today. The calculations were at that time carried out by hand and the method was force based, not displacement based as we use it today. In the mid 60’s, very specialized computer programs were used to perform the analysis. The 1970’s was the time when commercial programs started to emerge. At first, FEM was limited to expensive mainframe computers owned by the aeronautics, automotive, defense and nuclear industries. However, in the late 70’s more companies started to use the FEM, and since then, the usage have grown very rapidly.

Today commercial programs are very powerful and large, complex problems can be solved by one person on a PC. Many of them have the possibility to handle different kinds of physical phenomena such as e.g. thermo mechanics, electro mechanics and structural mechanics. One often talks about multiphysics, were different kinds of physical phenomena are coupled in the same analysis. There are many available commercial programs, ABAQUS, FLUENT, Comsol Multiphysics, and ANSYS are just a few examples. A full license of a finite element analysis program costs usually in the order of several ten thousands Euro. ANSYS is a widely used commercial general-purpose finite element analysis program.

Basic program structure

Treatment of engineering problems basically contains three main parts: create a model, solve the problem, analyse the results. ANSYS, like many other FE-programs, is also divided into three main parts (processors) which are called preprocessor, solution processor, postprocessor. Other software may contain only the preprocessing part or only the postprocessing part. During the analysis you will communicate with ANSYS via a Graphical User Interface (GUI), which is described below and seen in Figure 1.
1. **Utility menu**: Here you can access and adjust properties about your session, such as file controls, listing and graphic controls.

2. **Toolbar**: Push buttons to commonly used commands.

3. **Main menu**: Here you can find the processors used when analysing your problem.

4. **Graphics window**: In the graphics window your model is displayed: geometry, elements, visualisation of results and so forth.

5. **Input window**: You can type commands in the input window.

---

Figure 1: The ANSYS Graphical User Interface (GUI).
**Preprocessor**

Within the preprocessor the model is set up. It includes a number of steps and usually in the following order:

- **Build geometry.** Depending on whether the problem geometry is one, two or three dimensional, the geometry consists of creating lines, areas or volumes. These geometries can then, if necessary, be used to create other geometries by the use of boolean operations. The key idea when building the geometry like this is to simplify the generation of the element mesh. Hence, this step is optional but most often used. Nodes and elements can however be created from coordinates only.

- **Define materials.** A material is defined by its material constants. Every element has to be assigned a particular material.

- **Generate element mesh.** The problem is discretized with nodal points. The nodes are connected to form finite elements, which together form the material volume. Depending on the problem and the assumptions that are made, the element type has to be determined. Common element types are truss, beam, plate, shell and solid elements. Each element type may contain several subtypes, e.g. 2D 4-noded solid, 3D 20-noded solid elements. Therefore, care has to be taken when the element type is chosen.

  The element mesh can in ANSYS be created in several ways. The most common way is that it is automatically created, however more or less controlled. For example you can specify a certain number of elements in a specific area, or you can force the mesh generator to maintain a specific element size within an area. Certain element shapes or sizes are not recommended and if these limits are violated, a warning will be generated in ANSYS. It is up to the user to create a mesh which is able to generate results with a sufficient degree of accuracy.

**Solution processor**

Here you solve the problem by gathering all specified information about the problem:

- **Apply loads:** Boundary conditions are usually applied on nodes or elements. The prescribed quantity can for example be force, traction, displacement, moment, rotation. The loads may in ANSYS also be edited from the preprocessor.

- **Obtain solution:** The solution to the problem can be obtained if the whole problem is defined.
Postprocessor

Within this part of the analysis you can for example:

- **Visualise the results**: For example plot the deformed shape of the geometry or stresses.
- **List the results**: If you prefer tabular listings or file printouts, it is possible.
**Tutorial 1: Truss problem**

You will now use ANSYS to analyse your first problem. It is taken to be the simple truss problem shown in Figure 2. The truss is fixed in the left wall and the load of 10 000 N is equally distributed on the two upper right joints. It is made of wood with Young’s modulus 16 GPa (parallel to fibers) and cross sectional area 25 cm$^2$. It is recommended that you use SI-units for all quantities in order to obtain a result in SI-units. Saving your model is optional but recommended.

![Figure 2: A balcony truss.](image)

To analyse this problem we will go through the following steps:

1. define the **geometry**
2. define the **material**
3. choose **element type**
4. create **mesh**
5. apply **loads** and define boundary conditions
6. **solve the problem**
7. **process the results**
Start ANSYS. Your model can be saved in a database by specifying your working directory (the folder where you want your ANSYS files to be saved) and a job name (every problem has a job name, for example truss).

ANSYS Utility menu: **File → Change directory …**

ANSYS Utility menu: **File → Change jobname …**

**Geometry**

We will now draw the structure shown in Figure 2 by first defining keypoints and then drawing lines between them. A visible working plane often makes the creation of the geometry easier. Therefore:

ANSYS Utility menu: **WorkingPlane → WP Settings …**

Change to “Grid and Triad” (triad meaning a triplet of base vectors) and set the minimum and maximum to 0 and 2 respectively, OK.

ANSYS Utility menu: **WorkingPlane → Display Working Plane**

We will now define keypoints at the joints of the truss, see Figure 3 for the location of the keypoints.

ANSYS Main menu: **Preprocessor → Modeling → Create → Keypoints → In Active CS**

Press Apply to create the first four keypoints. Press OK to create the last keypoint and close the dialog box.

<table>
<thead>
<tr>
<th>Keypoint</th>
<th>x</th>
<th>y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>1</td>
</tr>
</tbody>
</table>

Figure 3: Keypoint coordinates and input dialog box.

We will now create lines between the keypoints, see Figure 4.

ANSYS Main menu: **Preprocessor → Modeling → Create → Lines → Lines → Straight Line**
Press Apply to create the first five lines. Press OK to create the last line and close the dialog box.

<table>
<thead>
<tr>
<th>Line</th>
<th>KP1</th>
<th>KP2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>4</td>
<td>5</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>3</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>3</td>
<td>5</td>
</tr>
</tbody>
</table>

Figure 4: Lines and keypoints.

**Tip:** You can check your geometry in the graphics display:

ANSYS Utility menu: **Plot → Keypoints → Keypoints**

or

ANSYS Utility menu: **Plot → Lines**

Numbering of lines and keypoints on the graphics display can be turned on and off in the dialog box after selecting

ANSYS Utility menu: **PlotCtrls → Numbering**…

**Material**

We assume that the wood behaves linearly elastic. Define the material model and the material constants, see Figure 5:

ANSYS Main menu: **Preprocessor → Material Props → Material Models**
Enter 16e9 for Ex (Young’s modulus) and 0.3 for PRXY (Poisson’s ratio).

Save your database:

ANSYS Toolbar: SAVE_DB

**Element type**

The element type to use is called **link1**. Add this element from the library:

ANSYS Main menu: Preprocessor → Element type → Add/Edit/Delete → Add…

The cross sectional area of the elements in the truss structure also has to be defined. This is accomplished with a so called real constant set:

ANSYS Main menu: Preprocessor → Real Constants → Add…

Choose the element type link1, OK. Fill in the value of the cross sectional area in the box (Note: use SI-units, i.e. m^2!), OK. *In case we would like to define different cross sectional areas for the same element type, multiple real constant sets would be required.*
**Mesh**

In this step we will discretize our geometry by creating an element mesh

ANSYS Main menu: **Preprocessor → Meshing → MeshTool**

Under *Element Attributes* Select *Lines*, click *Set*. In the dialog box that appears, select the lines which should be associated with your real constant set number. In this case, *Pick all*. Now the dialog box shown in Figure 7 will appear. Check that the material number, real constant set number and element type number are the ones that you have defined, OK.

![Figure 7: Line element attributes.](image)

We want each line to be divided into one element only. This is accomplished under *Size Controls, Lines*, click *Set*. Select *Pick all* in the dialog box that appears. Specify $NDIV$ to 1 in the new dialog box, click OK. This step is **very** important in order to avoid creating a mechanism.

Then click *Mesh* on the mesh tool, *Pick all*. Elements and nodes will now be created on the lines.

**Tip:** Element and node numbering and display can be activated similarly to keypoints and lines. Do this to check your elements and nodes.

**Loads**

The displacement is prescribed to zero at the two joints to the left:

ANSYS Main menu: **Solution → Define Loads → Apply → Structural → Displacement → On Nodes**

Click on the appropriate nodes, OK. Select $ux$ and $uy$ and set the value to 0, OK.
The force is prescribed at the two outer joints:

ANSYS Main menu: **Solution → Define Loads → Apply → Structural → Force/Moment → On Nodes**

Choose the $y$-direction and the value $-5000$ (the minus sign indicates that the force is directed in the negative $y$-direction).

**Solution**

The problem is now defined and ready to be solved:

ANSYS Main menu: **Solution → Solve → Current LS**

Save your database:

ANSYS Toolbar: **SAVE_DB**

**Results**

Enter the postprocessor and read in the results:

ANSYS Main menu: **General Postproc → Read Results → First Set**

Now there are several results to study. We begin with the displacements:

ANSYS Main menu: **General Postproc → Plot Results → Deformed Shape**

The undeformed and deformed shape should be similar to what is shown in Figure 8.

![Figure 8: Undeformed and deformed mesh.](image-url)
We can also choose to list the displacements:

**ANSYS Utility menu:** List → Results → Nodal solution …

In the dialog box select Nodal solution, DOF solution and X-displacement components, click Apply. Repeat for Y-displacement components.

Next, axial forces may be of interest. For the current element type, the axial force is stored in a variable called SMISC, 1. We can choose to list them:

**ANSYS Main menu:** General Postproc → Element Table → Define Table… → Add…

Write your own label (force), select Results data item: By sequence num – SMISC, add the item number 1, see Figure 9.

![Figure 9: Define element table item.](image)

**ANSYS Main menu:** General Postproc → Element Table → List Element Table…

Select your data item from the list, OK.

Reaction forces can directly be obtained from the list menu:

**ANSYS Utility menu:** List → Results → Reaction solution …

Save everything and you are ready for the next tutorial.
**Tutorial 2: Beam problem**

In this second tutorial you will analyze a simple problem where beam type elements will be used. The structure to be analyzed is shown in Figure 10. The material is aluminum with Young’s modulus 70 GPa and Poisson’s ratio 0.3. The beam has a rectangular cross-section with the height 6 cm and the area 24 cm². It is recommended that you use SI-units for all quantities in order to obtain a result in SI-units.

![Figure 10: A beam structure.](image)

Follow the general steps outlined in the previous tutorial in solving this problem. If you continue after the previous tutorial you should start a new job:

**ANSYS Utility menu: File → Clear & Start New**

**Geometry**

Just as in the previous tutorial define keypoints in the current coordinate system. In our current problem the three keypoints can be chosen as (0,0), (1,0) and (1,-1). Once you are done with the keypoints create the two lines between these.

**Material**

Define the material model and the material constants.
**Element type**

The element type to use is called **beam3**. Add this element from the library:

ANSYS Main menu: Preprocessor → Element type → Add/Edit/Delete → Add…

The cross sectional area, height and moment of inertia of the beams also need to be specified. Again, do this with the real constant set:

ANSYS Main menu: Preprocessor → Real Constants → Add…

Choose the element type beam3, OK. Fill in the values of the cross sectional area, height, and moment of inertia (IZZ) in the box (Note: use SI-units, i.e. m²!), OK.

**Mesh**

You are now ready to create the element mesh, follow the steps outlined in the previous tutorial. Here you can choose to mesh each line with one or more elements (set NDIV).

**Loads**

As the left end of the beam is clamped, all displacement components and the rotation are prescribed to zero at the corresponding node (0,0):

ANSYS Main menu: Solution → Define Loads → Apply → Structural → Displacement → On Nodes

Click on the appropriate node, OK. Select All DOF and set the value to 0, OK.

Apply the force 5000 in the x direction on the node at (1,-1), follow the steps in the previous tutorial.

Now we will apply the moment at the coordinate (1,0):

ANSYS Main menu: Solution → Define Loads → Apply → Structural → Force/Moment → On Nodes

Click on the appropriate node, OK. Choose Mz and the value 7000, OK.

Finally we will apply the pressure on the top beam. Choose

ANSYS Main menu: Solution → Define Loads → Apply → Structural → Pressure → On Beams
Select the appropriate line, OK. In the dialog box that appears enter 10000 for \(VALI\) and click OK. Note that you can specify a linearly distributed load by entering a value for \(VALJ\), which is the value at the other (right) end of the line. As our load is uniform that field should be left blank. When finished the uniform load will show up on the horizontal element.

**Solution**

The problem is now defined and ready to be solved:

ANSYS Main menu: Solution → Solve → Current LS

**Results**

Enter the postprocessor and read in the results:

ANSYS Main menu: General Postproc → Read Results → First Set

Now there are several results to study. Plot the deformed and undeformed shapes, this has been described earlier.

Next, axial forces may be of interest. We can choose to list them:

ANSYS Main menu: General Postproc → Element Table → Define Table… → Add…

Write your own label (force), select Results data item: By sequence num – SMISC, 1.

Add results for the moment by repeating the above steps and add the data items SMISC, 6 and SMISC, 12. For the current element type these variables define the bending moment at the left and right end of the element, respectively.

These items can be studied by listing them

ANSYS Main menu: General Postproc → Element Table → List Element Table…

Select your data item from the list, OK.

It is also possible to plot the moment distribution for the beams:

ANSYS Main menu: General Postproc → Plot Results → Contour Plot → Line Elem Res

Select SMIS6 for “LabI” and SMIS12 for “LabJ”, OK.

Nodal solutions can be listed as outlined previously. In addition to \(x\)- and \(y\)-displacements we may also list the \(z\)-component of rotation:

ANSYS Utility menu: List → Results → Reaction solution …